RC8: VST not torking on Linux

Having trouble with LMMS? Ask about it here.
Hi there,

I'm a newbie here, just created this account to report a bug.
VST plugins (32bits dll) that worked fine until RC7 with Wine on Linux (although VST instruments windows freeze and it is needed to switch windows and get back to LMMS to be able to click on those again) now when VST instruments are loaded LMMS just freezes or nothing happens.

My kernel: x86_64 Linux 4.19.24-1-MANJARO

Thank you in advance.
Confirmed, opensuse Leap 64 bit.

I just downloaded rc8 and tried vestige.

If lmms does not freeze the vst does not produce any sound.

Tried to load a minimoque, and LMMS freezes.
I could load 4Front piano, but although it does not freeze lmms, its silent on rc8, working fine on rc7.

I am reporting this on discord, will report here when I get an reply :)
No real news yet, tech talk seems to be the right spot to report this, not dev talk were I posted this first ( Discord lmms )

We do know the devs have seen it, so now we wait. :)
Can you try disabling "Sync VST plugins to host playback" in settings and see if that fixes the issue?
That did solve the problem for me. :)
Our Devs are talking about it.

https://github.com/LMMS/lmms/issues/4861
InSuccession wrote:
Thu Feb 28, 2019 6:07 pm
Can you try disabling "Sync VST plugins to host playback" in settings and see if that fixes the issue?
Worked for me too, thanks a lot. However, VST window still freezes and I need to switch to another task, than return to LMMS to be able to regain control. I usually press CTRL+ESC to bring up the task manager, click ESC again to close it and this procedure, unfreezes LMMS controls.

Who is online

In total there are 7 users online :: 0 registered, 0 hidden and 7 guests (based on users active over the past 5 minutes)
Most users ever online was 238 on Wed Oct 23, 2019 11:40 am

Users browsing this forum: No registered users and 7 guests