Thanks, I'll use

Code: Select all

libQt5Core-devel libqt5-qttools libqt5-qttools-devel
and if people complain, we'll update it accordingly.

Edit: done. Will publish to LMMS in a few days.
zypper info LMMS I think that will only gives us the non-development dependencies. Here's the temporary wiki I'm working from: https://github.com/tresf/lmms/wiki/dependencies-opensuse I just need the qt5 packages that one would use to setup the build environment. Usually something like "libqt5 libq...
Libsoundio is one of several back-ends we support, so yes, it is still optional. I don't see any reference to qt4, qt5 or any devel packages for qt installed. Can you list the qt packages you have already installed with zypper? Thanks kindly for this information! We're revamping our compilation tuto...
Thanks for sharing! You may also find some feedback in our #projects channel on discord.

https://discord.gg/5kSc32Z
Thanks for sharing!

If you're looking for people to help out with your project, you may have luck hunting around for LMMS musicians on Soundcloud or hanging in the LMMS discord chat server. https://discord.gg/5kSc32Z

The puppeteering is good in your video. Thanks for sharing your hard work!
The git message can be ignored. That tries to use github to fetch the version number (e.g. 1.2.0-rc2.27). It will append 27 for you automatically so you know you're 27 changes after rc2 release. :) In regards to the build errors, the only missing mandatory package is sndfile, probably called libsndf...
I'd rather not argue the fundamentals of software freedom. That's really not the FOSS model. That's the source code/GPL model. As a maintainer of other open source projects, I feel qualified to tell you what works. I'm sorry if that comes off as condescending. That's not my goal. My goal is to tell ...
You make the developers feel the same way when you don't even test out our branch. Don't think you're the only one jumping on these forums to "help someone". <3
If Packman can't fix it, because there is a problem with LMMS and openSUSE, I will file a bug report. If you read my posts, you'd realize there are problems. Wine version problems specifically. 1.2 hasn't been released so you're inconveniencing hard working package maintainers without taking the ti...
LightZ wrote:
Mon Feb 27, 2017 7:21 am
@ LightZ,
I strongly recommend you swing on over to GitHub, our devel mailing list and discord.

A Java background is just fine for starters. We need all the help we can get!

https://lmms.io/get-involved/