AppImage for Linux LMMS

Got a great idea for the future of LMMS? Post it here.
Forum rules

Make sure to search to see if your idea has been posted before! Check our issue tracker as well, just to make sure you are not posting a duplicate: https://github.com/LMMS/lmms/issues

With AppImage http://appimage.org/ it is possible to make independent Linux Distro executables by packaging the required dependencies with the Programm.
AppImages run without installation or the need for root rights on Arch, CentOS, Debian, Fedora, Opensuse, Ubuntu....

I made an AppImage for LMMS with VST enabled but you must have a WINE version installed for working VST's. (nothing happens when loading a VST .dll if there is no WINE on your System https://www.winehq.org/ )
Download for 64 bit Linux:
http://www.mediafire.com/download/b9g85 ... 2.AppImage ~32MB (recommended download)
http://www.mediafire.com/download/3h4th ... 2.AppImage ~26MB (if you encounter qt4 problems with the recommended download try this one)

32 bit VSTs only and LMMS-VST AppImage should run on every 64 bit Linux.
I had to remove the JACK audio system in this LMMS-VST AppImage because it has strange behaviour with the AppImage Software.
You have to make the .AppImage executable: right-click --> Properties --> and check "make executable" or by command line "chmod a+x LMMS_VST_Qt4_x64_r02.AppImage".

Why not make an official AppImage for LMMS? I can post instructions on how to make an AppImage if the developers are interested.
-sk1re- wrote:With AppImage http://appimage.org/ it is possible to make independent Linux Distro executables by packaging the required dependencies with the Programm.
AppImages run without installation or the need for root rights on Arch, CentOS, Debian, Fedora, Opensuse, Ubuntu....

I made an AppImage for LMMS with VST enabled but you must have a WINE version installed for working VST's. (nothing happens when loading a VST .dll if there is no WINE on your System https://www.winehq.org/ )
Download for 64 bit Linux:
http://www.mediafire.com/download/b9g85 ... 2.AppImage ~32MB (recommended download)
http://www.mediafire.com/download/3h4th ... 2.AppImage ~26MB (if you encounter qt4 problems with the recommended download try this one)

32 bit VSTs only and LMMS-VST AppImage should run on every 64 bit Linux.
I had to remove the JACK audio system in this LMMS-VST AppImage because it has strange behaviour with the AppImage Software.
You have to make the .AppImage executable: right-click --> Properties --> and check "make executable" or by command line "chmod a+x LMMS_VST_Qt4_x64_r02.AppImage".

Why not make an official AppImage for LMMS? I can post instructions on how to make an AppImage if the developers are interested.
You might want to hit up the fellows on GItHub about this and open an issue. . It sounds like you've done most of the work already
Sound great but also a lot of work. And for most distro's there is already a package in the official repositories.
Beta AppImage available here: https://github.com/LMMS/lmms/pull/3688

Who is online

In total there are 5 users online :: 0 registered, 0 hidden and 5 guests (based on users active over the past 5 minutes)
Most users ever online was 131 on Sat Dec 10, 2016 3:47 pm

Users browsing this forum: No registered users and 5 guests