In order to get the best compatible version of LMMS, you can install it from the command line like so:

0. Make sure you have an internet conmection
1. Search for a thing called the "terminal" and write down "su" if you are operating on Debian, or "sudo" for Ubuntu. (no quotes)
2. Then, write down your admin password.
3. Write this: (CTRL-C + SHIFT-CTRL-V in terminal)


sudo apt-get install lmms


apt-get install lmms

4. Press "y" if required by terminal
5. Give the terminal some time to finish and then close it.
6. Search for LMMS and go ahead and use it!