Solving No sound/Distorted sound problem

Write guides and how-tos about LMMS for other members.
If you don't hear any sound or if you hear distorted sound with LMMS, here's a walkthrough that will maybe solve it. It worked for me.
Follow those steps :
1. Open the run command (Shortcut : Windows key + R).
2. Write "dxdiag" and push "ok" (or press Enter).
3. A window will appaear. Now click in the "sound 3" tab.
4. Look at the right of the window : there's information about the driver. Look at driver's name and write this name on a paper or keep the window open until walkthrough's end (you will need to write this name back later).
Image
5. Now start LMMS.
6. Go in the "Edit" tab. Click on "configuration and go in audio configuration.
7. Select SDL (Simple DirectMedia Layer as audio interface.
8. Then, under "settings for SDL", write the driver's name (The name you had to remind about during the step#4.
Image

Then restart your LMMS and check if this worked. If this solved, it's ok. If this is still not solved, come back to the step#3 and try to get driver's name from sound 1 or sound 2 tab instead of sound 3.

I personnaly had that problem and this walkthrough solved my problem.
OMG!!! Thank you so much! your the best. It works now! :D
No problem dude
By the way I want to say something : when I found this trick the current version of lmms was there version 10. Current one is 12 so...I think this trick must still work but if it doesn't work anymore maybe it's due to this !
This works with version 13. A million thanks dude!!!

It's a pity that not much material exists for working with LMMS on Windows.
Darkill, Many thanks for your help. You Rock!!!

Cheers,
Jarr :)
The 'configure' icon doesnt appear in edit on version 0.4.13, and I cant find it anywhere else. Help me out here?
The 'configure' icon doesnt appear in edit on version 0.4.13
what version?
in windows-version its:
edit|settings| <click 'loutspeaker-icon'> field <audio-interface>
There should be drop-down there
click and choose SDL

br
Thanks for the info.
It worked for me.
This aspect for Windows users should definitely be in the Installation Guide.

Many thanks,
Alan
:? Alot of people should see this Topic. It'll help them alot.
Re: Darkill

After entering dxdiag, there are sound1 and sound2 tabs.

In sound1 "Default device: Yes"

So i used its name and typed it in the audio configuration settings you mentioned.

So whoever has this problem, first check default device: if yes, use that name, it works.

It worked for me.

Thank you Darkill for your tutorial on troubleshooting this problem.

Who is online

In total there are 4 users online :: 0 registered, 0 hidden and 4 guests (based on users active over the past 5 minutes)
Most users ever online was 131 on Sat Dec 10, 2016 3:47 pm

Users browsing this forum: No registered users and 4 guests