Automation record problem

Having trouble with LMMS? Ask about it here.
Hi
I recently found the automation record feature.
I took a project I was working on and added 3 automation tracks to one of the instruments.
Volume, Frequency and resonance ( the latter two from a plugin Calf Filter LADSPA).

The system allows me to record the automation whilst it is playing and as I expect I can twiddle the (onscreen) control knobs and alter the three parameters.
Everything looks good.
Once I have finished recording I turn off the record mode and play back the track, but what I hear is different to what I had recorded.

In particular I check the filter automation graph. It looks good in that it follows the changes that I was making, however the scaling is wrong. The frequency graph is in a much lower range than I had recorded, and for that reason much of my track is silent.

My system is LMS 1.2.0-rc8 on Ubuntu 18.04.

I'm sure this is a bug.
More information.

Just incase I have updated my lmms version from rc8 to the new stable release.
I tried again and I varied the frequency between 197 and 2400.
I checked the recording and the frequency record varies between 10 and 80.
And still more info.
I make a track with just one automation - frequency (range of the pot is 10 - 20000) It records the level changes but changes them to be a much lower range. SO is useless to play back.

I delete the automation track and add a different automation track - resonance (range on the pot is 0-32) This records and plays back OK.

It appears that the automation recorder cannot handle the larger range of values 0 - 20000 but is OK with smaller ranges like 0 - 32.
janika wrote:
Tue Aug 13, 2019 10:17 am
My system : 1.2.0-rc8 on Ubuntu 18.04.
Dont use any RC LMMS has been off released as 1.2.0
This is the version you need to install: the AppImage on the Linux-tab!
This is however only available as x64
https://lmms.io/download/#linux

Rem. to backup before you reinstall!
Let us know the outcome :)
Thanks. As I said in my second post I have already upgraded the version to the latest stable release. Still the same problem.
It's actually logging the wrong values while you are recording.
I start with the frequency of the filter set to 2200 on the dial and don't move it any more.
I set the automation track to recording on.
I play the song and then look in the automation window and the value recorded is 63.
I can post you the file. I'm not sure if I can attach it here?
https://www.dropbox.com/s/rvwab2eqa2x3q ... .mmpz?dl=0

The above project will demonstrate the problem.
Still more information on this problem.
Ive written down frequency values as I varied the control pot and I've compared them with what are logged in the automation.

The control pot is logarithmic, but the automation values are perhaps being logged using a linear scale.
Lower values are being attenuated but it is lass obvious with the higher values.


Someone need to look into this as it make recording of some automation impossible.
Maybe this should be reported at discord. :)

Who is online

In total there are 6 users online :: 0 registered, 0 hidden and 6 guests (based on users active over the past 5 minutes)
Most users ever online was 238 on Wed Oct 23, 2019 11:40 am

Users browsing this forum: No registered users and 6 guests