Change tempo for exporting

Having trouble with LMMS? Ask about it here.
I'm sure there is a stupidly easy answer for this, but I've searched everywhere I can think of and can't find it.

I need to change the tempo so that it actually sticks for exporting. I can use the toolbar to change the tempo for playback, but when I export the music it always reverts to 100 BPM.

How do I get the tempo to stay where I set it for the export?

Thanks in advance!
That's odd, I'm not experiencing that problem. I doubt I can help but someone else might be able to with more information.

Are you using version 0.4.8?
Windows or Linux?
Does the tempo setting change in LMMS or is the exported file just slower than it should be?
What settings are you using during export?
I'm running LMMS 0.4.8 on a Dell Studio XPS 16 with Windows 7 Home 64bit.

When I go through the export process, I can see the BPM number on the toolbar change back to 100. The resulting file is then slower.

I am exporting with WAV using default settings.

The music I am trying to export is based on importing a piano-only MIDI file, and I am using the Steinway soundfont from the following page:

I should also note that this is my first ever attempt at using LMMS, although so far everything else seems to be working as I would expect it to.
Alright, I just downloaded a midi file real quick and imported it in LMMS, then exported it to wav. While it was working I noticed the tempo change from 220 to 110 and then back to 220. I looked through the automation tracks but I have no idea how it manages to do that. My export also didn't work at all (no sound in the wav file). I'm guessing here that you were trying to change the tempo of the song but that information is already coded into the midi file (and somehow into the project once imported).

Alright, I did some digging, and I found the automation track in the midi I was working with:

Code: Select all

      <automationpattern name="Tempo" pos="0" len="46080" >
        <time value="220" pos="0" />
        <time value="110" pos="35664" />
        <time value="220" pos="46032" />
        <object id="1705842" />
The problem is, I didn't see this in the Song Editor GUI. Looks like if you want to change the BPM on a project that was created from an imported midi, you'll have to save it as .mmp open in a text editor and find the tempo automation track and delete it.

-Edit- It was located near the end of the file, before the fxmixer/fxchannel stuff.
That worked! :D

Many thanks!
ahh! you were talking imported midis, thats a complete different story. An other 'hack' can be used. A project will use the last imported midi as template for the BMP settings. So if you have tiny midis with only BMP information and one note, you can use these to 'import' a BMP in to a project based on another midi. In a way 'override' the larger midifiles BMP setting.