midi keyboard as controller - settings help please - thank u

Having trouble with LMMS? Ask about it here.
Hi all,

Happy Saturday. I have run into a wall using LMMS using Windows 10 and an m-audio keystation 88es connected via USB.

I get sound using the keyboard. I see that LMMS works without a keyboard better. But for musicians, having to use a computer keyboard versus a music keyboard is a real bummer.

I'm looking for concrete information on the midi settings that need to be used to get my keyboard up and running past the connection stage only. I've read the manual cover to cover. I've looked at the quick set-up and the midi wiki chapter. Actual information isn't easily available I'm finding.

I connected the keyboard to LMMS just fine in the settings tab.

I downloaded a sample which plays across multiple keys just fine using the keyboard. However, I'm now ready to use the keyboard for the next track. And I've hit a wall. All I hear when attempting to set up another track is the sample from the first track. The sample plays and meters on the first track though I've enabled channel 2 on Midi input on a new track. On the new track, when I hit the keys in piano roll - the new sound plays/records. But when I use the keyboard, I hear the sample from input channel 1 playing.

I noticed that there is no concrete information about the midi settings that need to be used beyond how to get LMMS to recognize your keyboard as a midi device and how to use it on one track. Which input/output settings do I need to use to have the keyboard functioning on multiple tracks? I want to program drums, bass, guitar and percussion on multiple tracks.

What channels do I use for MIDI INPUT and MIDI OUTPUT? Are there any other settings that are relevant such as in audio, which I saw reference of but no one answered the guy's question?

The 88es playstation keyboard doesn't have a global channel that I can see in the manual, but it says it can transmit midi on 16 channels. I shouldn't have to change the midi channel on the keyboard for every track because I want to play the other tracks I've already recorded etc. as well as record new ones.

In other programs, there is a very simple process for enabling a midi keyboard to play smoothly. I'm sure I'm missing something on LMMS. Thanks for your direction, fellow writers!
coolvibez wrote:
Sat Sep 16, 2017 9:28 pm
Hi all,
Hi, Welcome to the forum coolvibez! Here are all our important links:
viewtopic.php?f=1&t=4740
-And a few rules for Avatars, signatures, posting and using the right sub-forum :)
If you like to introduce yourself, to the community:
viewtopic.php?f=4&t=4480

I dont own a keyboard, sp i cant assist you- However what i can do is pinpointing the actual facts, in your long post:
Which input/output settings do I need to use to have the keyboard functioning on multiple tracks?
That is what you need to get an answer for

This may also be of relevance:
What channels do I use for MIDI INPUT and MIDI OUTPUT? Are there any other settings that are relevant such as in audio, which I saw reference of
Now a keyboard owner / wizard need to visit here :)
When you say you want it working on "multiple tracks" I assume you actually mean on several tracks but only one at a time. And you don't really need MIDI OUT. Just MIDI input from the keyboard to LMMS. If not ignore everything below;).

If the first track was working on MIDI channel 1 then that's what your keyboard is sending so you need to set the same channel for the next track. And because you only want to hear/record that second track being played by the keyboard you need to switch MIDI off on the first track. From what I remember LMMS doesn't have any simple way of doing that like a record arming button or similar. You can either, for that first track, use the gearwheel thingy in Song Editor select MIDI Input and untick your keyboard or go into the MIDI page and switch the green light off. It's a bit of a pain but it works for me.

Steve
Thanks for your help, Steve! Other programs do it through settings, and you never have to think about it again. But the work around works for me! I saw someone mentioned a "midi through" function on reddit that supposedly solves the problem also. And I saw a guy's set up on a Youtube tutorial where he had "midi through" checked, but my LMMS version didn't seem to have a "midi through" option. Protools uses midi through, too, and many others.

Re. my long post someone mentioned, I found several just like it in the forums discussing the exact same problem and no one answered. When people take the time to provide feedback, it's always a good thing. Whoever updates the manuals needs to read all the irrelevent things I mentioned in my "long post" and maybe there would be no more long posts on the topic. Have a great day!

Who is online

In total there are 20 users online :: 2 registered, 0 hidden and 18 guests (based on users active over the past 5 minutes)
Most users ever online was 131 on Sat Dec 10, 2016 3:47 pm

Users browsing this forum: Google [Bot], zeroc and 18 guests