VST Presets disappearing?

Having trouble with LMMS? Ask about it here.
So, I have this problem where I will load up a VST and do some stuff with it, blah blah blah, and then when I close and reopen the project, the presets go void or something and it makes no sound. So, I have to reload it and pick the preset again, and then go through it over and over again. I can't find where the presets for this plugin are located, which also sucks.
What should I do?
Details of the VST(s) you're having trouble with might help. I've used quite a few different ones but that's never happened with any of them (unless I've been moving things around to different locations).

Steve
This behavior is with one specific VST -right?
You cant reproduce the problem with any of these
https://lmms.io/documentation/Tested_VSTs
-right
Please post:
* OS (+service-pack-ver)
* lmms vers
* if any -screenshots of error
* names and best download links of the failing vst's
musikbear wrote:This behavior is with one specific VST -right?
You cant reproduce the problem with any of these
https://lmms.io/documentation/Tested_VSTs
-right
Please post:
* OS (+service-pack-ver)
* lmms vers
* if any -screenshots of error
* names and best download links of the failing vst's
I've got a free VST from Noizefield.com, called 4Tune. I'm using Windows 9, LMMS vers. 1.0.2.
So, when I open the VST after closing the project, the preset names are replaced with "Program 88" or "Program 46" and they come back when I reload the whole vst.
I'm using Windows 9, LMMS vers. 1.0.2.
Thats the first thing to change
Here
https://lmms.io/download/#windows
you find links to the much more stable and feature rich 1.1.3

Make sure you get the correct version!
DO remove (UN-install) old version before you re-install !! -But backup your own stuff first!

The retry your VST
Let us know the result
musikbear wrote:
I'm using Windows 9, LMMS vers. 1.0.2.
Thats the first thing to change
Here
https://lmms.io/download/#windows
you find links to the much more stable and feature rich 1.1.3

Make sure you get the correct version!
DO remove (UN-install) old version before you re-install !! -But backup your own stuff first!

The retry your VST
Let us know the result
I did retry it, and it still happened. :/
MY VST's are in a different folder than LMMS, they're on the desktop of my computer. Is that bad?
Plus, I can't find where the presets for the VST are located. Would moving those to the presets section of LMMS help?
Just given it a try and 4 Tune does the same for me with the VST .dll in my normal VST folder. OTOH if you save the preset you're using to your own filename (use the FIle button under the preset names) then when you reload the project you just have to load that preset again and it's working.

But I can't find any documentation for it so there could easily be something we're missing. But the basic presets seem to be internal to the VST because it doesn't install any files other than the .dll.

Steve
Just given it a try and 4 Tune does the same for me with the VST .dll in my normal VST folder.
@slipstick - do i understand you correctly? You ALSO see this dll disappear, if you open a saved project?

@Cobalt
Did you upgrade? -But if slipstick has the same issue, then its the dll that not compatible with LMMS - theres a few alas :/
No the dll doesn't disappear. What actually happens is:
1. Load 4Tune, select a preset, add some notes in Song Editor. It plays normally.
2. Save the project.
3. Reload the same project.
4. 4 Tune loads and looks o.k. but the notes don't play and the preset name has become "Program xx". If you look at the preset list by clicking on the preset name the list is full of entries called Program 1, Program 2 etc where it used to have a list of entries with names.

If at step 1 above you modify the preset and save it as a new file then at step 4 you can just reload that saved preset and it will play but all the other list entries will still be missing.

But the conclusion may still be that 4 Tune simply doesn't play well with LMMS and so isn't compatible. Shame, but it's the first one I've come across and there are many VSTs that do work including all of my current favourites.

Steve
But the conclusion may still be that 4 Tune simply doesn't play well with LMMS and so isn't compatible.
oh yes, several others does the same, some very high end like karikatune, and its something being looked at
Always make sure that:
https://lmms.io/documentation/Working_w ... d_problems

Who is online

In total there are 11 users online :: 0 registered, 0 hidden and 11 guests (based on users active over the past 5 minutes)
Most users ever online was 173 on Fri Apr 19, 2019 11:04 am

Users browsing this forum: No registered users and 11 guests