Unable To Find MIDI Controller/No "Input" Dropdown Menu

Having trouble with LMMS? Ask about it here.
Hello! I'm new to the forum, I've had LMMS on my computer for a while but only scarcely touched it. I'm almost a complete novice when it comes to using DAWs so I thought it would be best to come join the forum if I needed advice.

My current version of LMMS is 1.2.0-rc8. I'm running Windows 10, HP Laptop with AMD A9-9425 Radeon 5-core processor, 8GB RAM, etc etc. Idk how much of this is necessary, but I know they're commonly asked about.

The MIDI controller I'm using is the MIDI Fighter 3D by DJ Tech Tools. (Imagine my disappointment when I realized I could probably only use its *cool* features with Ableton or Traktor...) Despite LMMS not being the "preferable" DAW for the MF3D, when I used the two in the past (various times through 2018, but I believe I downloaded this version sometime in 2017), the MF3D worked like a standard MIDI Keyboard, each button a semitone apart.

However, that was my old laptop, an old version of LMMS, an old version of the MIDI Fighter Utility software. Currently, when searching for the controller as explained on the "Using MIDI" page, the MF3D does not appear under the "Input" *or* "Output" dropdown menus. For that matter, the "Input" menu does not appear at all. I've seen other people from as far back as 2017 having this issue whilst googling it, but have seen no solution. I'll attach screenshots of the menus in question.

Thanks much for reading and responding!

EDIT: I forgot to mention, the MF3D definitely still works. I'm almost positive this is an issue with LMMS. I think I downloaded the Beta version, because I read elsewhere "It's definitely a lot better and less buggy than the non-beta." Or something.

Image

Image

Image
ApolloJetic wrote:
Fri Apr 05, 2019 2:20 am
Hello! I'm new to the forum,
Hi, Welcome to the Forum ApolloJetic !
Here are all important links:
http://lmms.io/forum/viewtopic.php?f=1&t=4740
-A few rules and useful forum instructions

Firstly, i have to award you the (non-existent) high-order for excellence in describing a bug!
You have told us everything needed !

That makes it even worse, that i really cant explain this at all.
The MIDI-hw has worked, but now it wont work on RC8..

My only idea is a long-shot, and that would be the cable
* Did you connect in the right sequence:
Eg
* first into MIDI-devise
* turn midi-devise ON
* insert midi-cable in OFFed pc
* boot pc
* start LMMS
* soft-connect on MIDI-tab
If not try that

The Cable -Could it be 'broken'?
You could test in a store, or perhaps a friend has a MIDI-kb you could try it with?

Let us know the outcome ..
Thank you Musikbear for the welcome and response!

When you mentioned the order in which I were to plug things in, that definitely rang a bell. I knew to have the controller plugged in before launching LMMS, but I hadn't thought about the order in which I plugged the cable and device into each other. Though, it seems silly to think I would plug the USB in before the controller, but I thought I should try anyway, and I'm happy to report all is working well!

The order of operations I took was:

1.) Turn on PC. (I had forgot about plugging the controller in before this step until I came back to this thread)
2.) Plug the cable into the controller
3.) Plug the cable into the PC. (Note, the controller has no power of its own, it's dependent on the pc, so plugging it in turns it on)
4.) Start LMMS

I was able to find the MF3D under the MIDI tab as usual. I'm not sure what I may have done wrong last night since it felt like I was doing everything correctly; perhaps I had LMMS open, then plugged in the MF3D, then never unplugged it while restarting LMMS.
ApolloJetic wrote:
Sat Apr 06, 2019 4:45 am
able to find the MF3D under the MIDI tab
Great news! And yes it is a bit strange that it depends so much on sequence, but.. well it does :p

Who is online

In total there are 10 users online :: 0 registered, 0 hidden and 10 guests (based on users active over the past 5 minutes)
Most users ever online was 173 on Fri Apr 19, 2019 11:04 am

Users browsing this forum: No registered users and 10 guests