Everything I import is being played on piano

Having trouble with LMMS? Ask about it here.
I am very new to LMMS and I am having trouble with it. I recorded a guitar riff in audacity, I coverted it to midi and I imported it into LMMS. When i press play, it plays the guitar riff on piano instead of me hearing the riff like i recorded it.

I am very new to midi and song editing and all of that, so if you could help me that would be great :)
I think you should not have converted it into midi, but import the guitar track into the audio file processor.
Is it a wave (.wav) file ?

Don't forget to draw a note in the piano roll, were you want the track to play.



So this is what I think your problem is: your default instrument on the sf2 plugin is a piano, and to change that you can go to settings and edit it.

If this sounds too.complex to you try downloading (if you don't aldready have) a guitar soundfont and then check if you're getting the desired sound.