Issue with recording (with Soundfont Instruments)

Having trouble with LMMS? Ask about it here.
Hello fellow musicians !

I use the last stable version of LMMS on an asus laptop with Windows 10 and a midi keyboard plugged in, and I play exclusively with soundfont instruments because they sound better and more natural than VST ones. Everything works fine when I am just playing, but at the moment it is very difficult to use it for composition because there are huge issues with recording. Let me explain : when I record I can hear the instruments normaly, but for some reason the notes are all recorded an octave lower than they should be, and when I play the track LMMS crashes within a few seconds.

Is there a way to fix it and work with Soundfont instruments normally ?

I don't think that I had this issue with the older version of LMMS I used to work with a few years ago, so worse case scenario if it can't be fixed with the current one is there a way to download an older version and do you have any idea which one I should use ? Maybe I am wrong and I worked with VSTs at the time but it is worth a shot.

Thank you for your time
Steven wrote:
Sat May 08, 2021 6:00 pm
Hello fellow musicians !
Hi, Welcome to the Forum Steven !
Here are all important links:
-A few rules and useful forum instructions
If you like to introduce yourself, to the community, go here:

when I record the notes are all recorded an octave lower than they should be, and when I play the track LMMS crashes within a few seconds.

The crash is the worst issue here, so we ned to solve that first.

Lets test if lmms works
* Shut down all open programs
* shut down !Not sleep!! -your pc, wait 2 mins and reboot
* open lmms default -eg load no projects!
* open This project: "projects\demos\Greippi - Krem Kaakkuja (Second
Flight Remix).mmpz"
Press play.
What happens?

If you do not have a crash, then the installation of lmms works

If it crash then we go on to next test :p

First we need to eliminate your keyboard as reason -Please unplug the MIDI-keyboard, and repeat exactly the procedures, but this time only use the PC-keyboard as input-devise
Can you reproduce the crash?

If so, it could be a problem with a sound-font
To investigate that option you need a copy of your project, because you need to replace all current soundfonts with our basic TrippleOSC
Then test if you still get a crash
IF NOT we now know that its one of the soundfonts!

Then you need to insert each sound-font after another, and do test between each single one, until your project crashes

Lets hold it there, and let us know the result for each of these steps
Hello musikBear and thank you for your quick reply !

For the first test everything works fine, so the issue doesn't seem to be with the installation of lmms.

With the second step, things get interesting :
- If I use the PC keyboard as input there is no issue
- If I do as usual, notes are recorded an octave lower than they should, however I was mistaken : it doesn't crash after a few second of playing them. I can play them normally but it crashes as soon as I hit stop... and even if I move these notes it crashes anyway.

Then I realized something : my keyboard (M-Audio Keystation 88) doesn't have any velocity curve settings so I had to find a 3-step solution for that :
- I use the "loopMIDI" software to create a virtual midi port
- Then I use another software called "Midi Velocity Curve Changer" by Trombettworks (v1.2) that takes the keystation88 as input, changes the note velocity, then output that to the loopMIDI virtual port
- Finally I use the loopMidi port as midi input in lmms

Just in case I tested what happens when I use the Keystation88 directly as input in lmms, without using loopMIDI and the velocity curves changer, and everything works fine when I do that (right octave)...
If i use loopMIDI + the velocity curve changer with other instruments than soundfonts I don't have issues either.

=> It seems that loopMidi and/or the Velocity curve changer have a weird compatibility issue with the soundfont player in lmms, but I have no idea where it comes from.

I really need to use a velocity curve changer for the keystation 88 to sound like a real piano because it is really bad without that : if you play softly you almost can't hear the notes, and if you play a little stronger the notes are easily too loud, there is no in-between... For example with my current settings the range goes from 25 to 80 instead of 1 to 127 for it to soung good.

So I guess the new question is : How can I adjust the keystation 88 velocity curve and use the soundfont instruments in lmms without getting weird (corrupted ?) notes that make lmms crash ?