[openSuse Leap 42.2] missing VST support

Having trouble with LMMS? Ask about it here.
69 posts

I recently installed LMMS in openSuse Leap 42.2.
Unfortunately I can't find any VST plugin. I searched a bit through the net.
I only found that you a) need wine installed and b) configure LMMS installation decidedly with VST support.
I used the yast for installation, so I cannot retrace the configure options (or at least I don't know how).
But I observed yast installing wine extra for lmms. So I presume it was for VST.

Furthermore I found libvstbase.so and libvsteffects.so in /usr/lib64/lmms. Another hint for VST not completely being ignored by the installation.

I installed carla, also via yast. But to no avail. It doesn't show up in the instrument plugins folder inside LMMS. Even after I copied the respective directory to the presets directory (where I also found Kicker, TripleOscillator et al.).

Does anybody have a clue for this?
musician wrote:Hi,
First, Welcome to the forum musician! Here are all important links:
-And a few rules for Avatars, signatures, posting and using the right sub-forum :)
I recently installed LMMS in openSuse Leap 42.2.
Unfortunately I can't find any VST plugin.
Yes, a lot of pac-men forgets the needed support.
First i would like you to read:
http://lmms.io/wiki/index.php?title=Wor ... _.26_Linux
If this solves your problem, please report what you needed to do for your special distro, because other may benefit from it.
If it does not, then post that :p
I am on openSUSE 42.1 with vestige in lmms. :)

Did you add the packman repository ?


And install LMMS and wine from packman ?

If you dont know which version you have installed, in yast search for lmms and then look under versions.
There you can also switch from the opensuse to the packman version.
Gps wrote:I am on openSUSE 42.1 with vestige in lmms. :)
Good input Gps!
Here I am again. Thank you for the welcome message. I didn't find time and energy yet for the avatar thing. I will complete that later, if you agree.

I read all the stuff behind the links you gave me. But they don't fit my problem. Most of the time they are ybout other Linux distributions then mine.

And thank you to Gps for the infos.

I have the packman repository installed. But indeed the lmms-version came from elsewhere.
I switched to the packman version in yast. But still no VST in lmms :(

When I start lmms from command-line I get this terminal messages:

Code: Select all

Notice: could not set realtime priority.
VST sync support disabled in your configuration
The real time part we can ignore. ( its because we don't use a realtime kernel )

The vst part might be the problem.

Here is mine.

Code: Select all

guus@linux-0pkp:~> lmms
Notice: could not set realtime priority.
unique ID: smjb
RemotePlugin::DebugMessage: inputs: 0  output: 2
RemotePlugin::DebugMessage: creating editor
RemotePlugin::DebugMessage: editor successfully created
RemotePlugin::DebugMessage: failed getting shared memory
the unique ID part is what I see when I load a vst.

What version of lmms do you have installed now?
Does it say LMMS 1.1.3 on the top of the lmms window?

Do you have wine installed, and is wine also from packman ?

If so, we might need to talk to packman.

( if you do not have wine installed, or not wine from packman, I would advise you to first uninstall lmms, then install wine, the reinstall lmms. )


I can help you with contacting them, if you want to.

Not related to you're problem, but if you want to know what a realtime kernel is:
wine was NOT from packman. i have the packman repository installed. but how do i install wine or other programs from it? yast only offers wine from Main Repository.

now i found a way to see the packages of the various repositories in wine.
but my packman rep does not have wine. only some wine-related stuff. wineasio and wine-mp3-32bit.

my packman rep is from URL: http://packman.inode.at/suse/openSUSE_Leap_42.2/

maybe the wrong one?

can't tell the version of lmms. now it's uninstalled ;) but i guess it was the 1.1.3, since thats the version yast offers, and i took it from there.
I have to apologize.
I just checked lmms and wine in YAST, and wine does not come from packman, me bad.

Below two screenshots of my setup,
Do you have wine 32 bit installed ?

The first line in the second screen shot is wine 64 bit.
The second line is wine 32 bit.


After reading you're first post again. I have tried to install Carla too on opensuse but it did not show in lmms.
I could start Carla outside LMMS.

I wanted to talk to packman about it, but carla was ( is? ) a beta program.

Slightly off topic, one thing I like about Linux.
With a bit of effort, you can find allot.

One way to contact the guy writing Carla, is to post on the Linux musicians forum.

For me its not clear if the problem is carla, or the compiling of LMMS ( what packman does for us )
We could also talk with falk TX

https://linuxmusicians.com/memberlist.p ... ile&u=5052
Great stuff here! Very useful also for wiki
musician wrote: I didn't find time and energy yet for the avatar thing. I will complete that later, if you agree.
I dont know what you mean, there is no 'rule' about having an avatar ;P
We dont like HUGE avatars, because they load lousy, but you do not have to make one at all
69 posts