How do I use "VST" instruments that come in .mse files

Having trouble with LMMS? Ask about it here.
98 posts
Then it may very well be something that just doesn't work on M$. Or maybe it needs something I don't have on my system. Maybe something no one even realizes is going on with M$ windows 10 home vs other variations. Who knows. I just know it doesn't work on my laptop.
Its possible wine is better at handling this VST then actual windows, this sometimes happens with older software.

But just to be sure, you downloaded the 32 bit version ?
I've already tried both versions ... same result.
Jinx wrote:
Wed May 12, 2021 4:34 pm
I've already tried both versions ... same result.
Jinx, i did not come back to you because i dont get through to you..
Here: viewtopic.php?f=7&t=34384&start=20#p74817
You just questions my bughunting attempt, and thats not what you are suppose to do.
I try to make a 'template-situation' that is 100% reproduceable, you dont follow the guidelines, so for the last time..
Follow these instruction the the letter!
Report the result:

Code: Select all

Do this:
Go to C:\Users\<name>\Documents\lmms\samples
Create new folder C:\Users\<name>\Documents\lmms\samples\VSTinstruments
Use explorer to copy the dll-file from the zip-file and paste it with explorer into

Open lmms
fetch a VST from sidebar
use gren folder icon, and browse to C:\Users\<name>\Documents\lmms\samples\VSTinstruments
highlight and select the dll
press a key
What happens?
First off, Welcome to the Forum Monospace !
Here are all important links:
-A few rules and useful forum instructions
If you like to introduce yourself, to the community, go here:
Monospace wrote:
Wed May 12, 2021 3:01 am
Interestingly, I ran the VST in LMMS by using the dll in the folder. Instrument seems to have no sounds below C5- at least on the default (Solo Violin) patch.
Good find!

If you go to my yT channel you will see that i have dissected issues with that VST, and that it is both depending on installation, and most important of imported libraries
That specific VST could be compared to sound-fonts but is a bit cumbersome
I think I can confirm this no sounds below C5, with the default patch.

I remember moving the notes up, when testing this vst to hear anything.
> Follow these instruction the the letter!

If you insist....

> Do this:
> Go to C:\Users\<name>\Documents\lmms\samples

Navigating to that directory (replacing <name>) fails, because there is
no document called lmms in Documents. My local lmms directory is under
C:/jim/lmms, and VSTs are installed in c:/VSTplugins, and that's where
VeSTige looks for all VST files, instruments, special effects,
everything, as configured in LMMS.

> Create new folder C:\Users\<name>\Documents\lmms\samples\VSTinstruments

Failed. Documents/lmms does not exist (like I said, LMMS is not a
DOCUMENT, nor are its data folders, so it does NOT belong in Documents).

> Use explorer to copy the dll-file from the zip-file and paste it with
> explorer into C:\Users\<name>\Documents\lmms\samples\VSTinstruments

Also failed, again, Documents/lmms does not exist.

> Reboot

On Restarting, nothing of what I was running was automatically restored
by M$ as it should have been. I had to manually restart everything,
reset lots of apps, load videos on about six VLC windows for different
things I have loaded, completely redo the sessions on BOTH Firefox
windows because the session manager app is hosed, plus lots of other
stuff I should NOT have needed to do. Thanks for wasting about 15
minutes of my time that was 100% useless (you don't reboot or restart
just because you do something with data files. NOBODY does that on ANY
os (ok, maybe people had to do that on old IBM mainframes, and/or the old
tube-based "computers" from WAY back when, but nobody runs that stuff
anymore (at least, I hope not).

You reboot when either you need to patch the system itself (e.g., the
kernel on Unix, or whatever M$ calls it) or when you have a frozen task
that even kill -9 as root can't close (very rare, but I have seen it
happen ... once), or if you're upgrading hardware that is not hot
swappable, etc. Not for adding some stupid data file, or installing some
software program, or anything like that. Again, thanks for wasting about
15 minutes of my time for absolutely no reason.

> fetch a VST from sidebar

I take it you mean VeSTige. Did I always do.

> use gren folder icon, and browse to
> C:\Users\<name>\Documents\lmms\samples\VSTinstruments

Failed. No such directory.

> highlight and select the dll
> press a key
> What happens?

The same thing that would have happened ANY OTHER WAY: IT DID NOT LOAD
ANY INSTRUMENTS (even after correcting the incorrect paths you listed to
what I'm ACTUALLY using on my system and proceeding from there): NO
I am not a Windows expert, but I wonder if, c:/VSTplugins is the problem.

Also C:/jim/lmms is not standard. That's outside the windows directories. (or is windows not showing the entire path ?)

But lets see what Musikbear has to say.

Don't know how old you are, but first step with any computer system issues, is to try to reboot.
Even on Linux. :)
I'm not a windows expert either, but I do know that there are settings where you tell LMMS where your stuff is. I used those. Real VST files all work great. My M-Audio HAMMER 88 works great with them.

As for my age, I'm 55. I cut my teeth on both Unix and UNIX(tm), using the incredibly powerful vi editor as my editor of choice, until vim/gvim came along, but strongly prefer BSD4.2 over SYSV. And rebooting any Unix (or M$) system without a very specific reason is not normal. Back before my career (electronics with a specialty in telecommunications) took a major side-step into 16th Special Operations Wing Intelligence at Hurlburt Field, FL, just down Hwy 98 from me (I was an Intelligence Systems Analyst, meaning I got to play with the cool toys that never existed ... and neither did I, for that matter), I worked with computers a LOT. At Wing Intel, I also worked with M$ NT and 2000 (plus some other Unix stuff that didn't exist). So I know enough to say that if I install something outside of the normal M$ path, I can do that. You can do that with automatic installers, too (and if something is installed with an installer, you should do your configuring there). For example, I have Godot3, IrfanView, Piskel, Vim, Tcl/Tk, and more, all installed in c:/jim/bin (some of those have their own subdirectories in ~/bin). As long as you can tell whatever's looking for it in its settings, config files, your own $PATH, etc., it's ok. But if, in M$ stuff, there isn't a way to configure that, it probably isn't safe, because M$ developers, or at least some of them, are dumb enough to hard-code stuff like that. But we're not talking about M$ here, we're talking about open source, where real brains of real users go into the development. And there is a whole section in LMMS's settings to specify where everything is.

Check it out. Look under settings. You'll see that folder icon, which means directory settings. That's where you're able to move stuff around, as long as you make sure that where you put stuff is set in the corresponding path in the directory settings.

Oh, and btw, even at Wing Intel, on my unclass and secret systems, I still ran Cygwin. I had to ask myself for permission, and I never said no to myself. Couldn't do that on the high side (TS//SCI), though...but then, I didn't need to as it was Unix. :-) I used Cygwin on those and my system here because the Unix command line gives you FAR MORE power than any mouse+menu does. For example, let's look for every file named but NOT in my $HOME directory (on this laptiop, c:/jim) and save the list to list.txt. And this is just a trivial example. I could add sed and do some editing of the output, say change to with a simple regular expression and sed.

(21:49) % cd
(21:49) % find . -print | grep | grep -v > list.txt

But using the command line does NOT produce different results than the (for most people, including me) much slower menus plus mouse method. It just gets it done faster (usually much faster). And that's not all. At one point, I was asked for help on something, where someone needed to change the contact information in over 100 web pages for one squadron. It took him about 18 hours on the high side, and, when I used Zsh plus vim with a macro that I made for this purpose, using search plus regular expression search/replace, I got it done in about two minutes on the collateral (secret) system. I used the right tools for the job. I got exactly the same end result...just a "little bit" faster (two minutes vs 18 hours). And for those who don't know, vim (and its graphical version, gvim) is a modern replacement for the old vi editor, and has all of the immense power of vi, plus a lot more. Like vi, its learning curve is steep...very steep. But once you get past that, its power is beyond belief. And no, please don't start a comp.editors style flame war about emacs vs vi,....
Jinx, I'm finding it hard to exactly tell what's going on given the immense amount of information and how I'm not an expert by any means (musikbear's advice is an expert's advice, however), but I hope I've interpreted you correctly.
Did you copy only the dll or both the dll and the folder containing .mse files into your VST folder?
Because, as far as I can tell, your text implies you copied only the dll. Both the dll and the Instruments folder need to be in your VST directory.
(Even I'm using a Win10, and I doubt it has something to do with how you're using Windows Home.)
98 posts