LMMS in High DPI 2880x1620 Screen. Scaling?

Having trouble with LMMS? Ask about it here.
I am currently running LMMS on my Lenovo T540p with a 2880x1620 resolution screen and it is seriously starting to give my eyes a work out. Is there a compile flag or something I can do to make LMMS scale better to my screen resolution? I realize that I can just set the resolution lower, but I would like to find a better solution.
I think this is an issue that has come up before. I could be mistaken. It certainly is a problem with LMMS currently. I don't believe the current version supports scaling. It would have to be modified in the source code to use style-sheets or something like that, I think.

If you're using Windows, you could try pressing (<Windows logo key> + <=>) to pull up the Windows Magnifier. Modify the settings to only increase by 25% when zooming in/out... The magnification will then follow your mouse around. Maybe that'd be a temporary solutions to help your eyes?
I found a workaround for this problem if you are on a Windows computer. I was trying to find a solution for Photoshop which was having this same issue on my 4K display. The same solution worked with LMMS for me. Just follow the instructions for the Phosotohop fix, replacing LMMS for Photoshop in the file name.
FYI, once you do the step with the Registry edit, you don't have do that again when you want to fix another program that has this scaling problem.

http://neoshamon.blogspot.com/2015/06/a ... ew=sidebar
Let us all know if this works, so it can be added to knowledge base :)
This worked for me. Thanks!
crispyfoot wrote:I found a workaround for this problem if you are on a Windows computer. I was trying to find a solution for Photoshop which was having this same issue on my 4K display. The same solution worked with LMMS for me. Just follow the instructions for the Phosotohop fix, replacing LMMS for Photoshop in the file name.
FYI, once you do the step with the Registry edit, you don't have do that again when you want to fix another program that has this scaling problem.

http://neoshamon.blogspot.com/2015/06/a ... ew=sidebar
AHA, you are the one I need to credit for finding a workaround for the problem, thank you very much sir, earlier this month I made a post about the very same problem viewtopic.php?f=7&t=4956, but i could not remember who in this forum posted the fix! God bless and good day
crispyfoot wrote:I found a workaround for this problem if you are on a Windows computer.......
http://neoshamon.blogspot.com/2015/06/a ... ew=sidebar
Wooah! That is quite an interesting read.
How the heck did I forget about this post? :roll:
Thanks for the link crispyfoot. Much appreciated . :D
A few years later, Windows 10 now makes this easier.

1. Shift-RightClick the application icon and select 'Properties'.
2. Go to the 'Compatibility' tab.
3. Check 'Override high DPI scaling behaviour'. There are three options. 'System (Enhanced)' works for me.
arthurattwell wrote:
Sun Aug 05, 2018 1:11 pm
A few years later, Windows 10 now makes this easier.
Interesting! Thank for sharing.
Besides that, since you are new in Forum
Welcome arthurattwell
Here are all important links:
http://lmms.io/forum/viewtopic.php?f=1&t=4740
-A few rules and useful forum instructions
arthurattwell has the answer. This info should definitely be somewhere prominent. It took me a whiiiiiile researching and trying things out before I stumbled on this and I was definitely on the verge of giving up and trying another program. Right now regedit is the main solution coming up and honestly that's something most people shouldn't be doing.

Anyway, for me there is one extra step. Also separated out one of the steps so people don't gloss over it:

1. Right click the program icon > select Properties
2. click on the Compatibility tab
3. click on 'Change high DPI settings'
4. under 'High DPI scaling override' check the box next to 'Override high DPI scaling behavior'
5. click the dropdown under 'Scaling performed by' and select either "System" or "System (Enhanced)"

Restart the program (you don't need to restart your computer) and voila.

Who is online

In total there are 16 users online :: 0 registered, 0 hidden and 16 guests (based on users active over the past 5 minutes)
Most users ever online was 150 on Fri Apr 05, 2019 6:38 pm

Users browsing this forum: No registered users and 16 guests