Can't Drag Instruments Into Song-Editor

Having trouble with LMMS? Ask about it here.
Cannot drag new instruments into Song-Editor. Same issue with any instrument I try.

From Help->About: LMMS Version 1.2.0-rc7 (Linux/x86-64, Qt 5.11.2, GCC 8.2.1 20180831)
Running with i3 and Arch Linux. Not sure what else would be useful. Screenshot below.

Thanks so much in advance. Loving LMMS so far -- hope to be able to get back to it soon!

Image
I am confused, because with rc 7 on opensuse, I can drag instruments into the piano roll.

Did you compile it you're self ? I see you mention gcc ?

The Appimage file should be downloaded, then set the rights to be executable, and then you just double click it to start LMMS.
I used pacman:
Repository : community
Name : lmms
Version : 1.2.0rc7-1
Description : The Linux MultiMedia Studio
Architecture : x86_64
URL : https://lmms.io
Licenses : GPL2
Groups : pro-audio
Provides : None
Depends On : fftw fltk fluidsynth lame libgig libsamplerate qt5-x11extras sdl stk
Optional Deps : pulseaudio: pulseaudio support
wine: VST plugin support
Conflicts With : None
Replaces : None
Download Size : 13.62 MiB
Installed Size : 33.59 MiB
Packager : David Runge <dave@sleepmap.de>
Build Date : Fri 12 Oct 2018 05:33:47 PM EDT
Validated By : MD5 Sum SHA-256 Sum Signature
I'm noticing that this is a bit behind compared to https://www.archlinux.org/packages/comm ... 6_64/lmms/. Perhaps I need to update my package database? (i.e. pacman -Syy)
heartofavra wrote:
Tue Mar 05, 2019 12:26 pm
I used pacman:
Dont use pac-man
Use APP-Image:
https://github.com/LMMS/lmms/releases/d ... 4.AppImage

Let us know the outcome :)

Besides that, since you are new in Forum
Welcome heartofavra !
Here are all important links:
http://lmms.io/forum/viewtopic.php?f=1&t=4740
-A few rules and useful forum instructions
What musicbear said, and I know this is not the normal way for Linux users.

From my own experience and reading on this forum, I know there are many issues, with the LMMS versions from the official repositories of any distro.

One problem is that the package guys don't know LMMS very well.
They might look if it starts, and if it does they are done.
Then they need us the users, to tell them its not working right.

An easier solution is to do what musicbear said.
Its safe and works at least for most used distro's . Ubuntu, Mint, Arch, openSUSE and Fedora.

I have been using the appimage version for probably over a year now, instead of the version from the official repositories.

There is also RC 8 but there a issue vst related with RC8 on Linux. so for now get RC7. :)
That did it! Thanks so much everyone :)

Who is online

In total there are 9 users online :: 0 registered, 0 hidden and 9 guests (based on users active over the past 5 minutes)
Most users ever online was 173 on Fri Apr 19, 2019 11:04 am

Users browsing this forum: No registered users and 9 guests