Trying to make house, but feels like I am failing

Questions about producing? Ask them here.
98 posts
So how is your house music going Gps?
My music production has stopped, for now.

Been building new PC and it seems almost everything goes wrong.

Never had this many issues.


First video card did not survive putting it in the new pc.
Then allot of issues to have windows 10 installed UEFI.
Then had a weird screen when I turned on pc. (nobody seems to know what's wrong but I did solve it.)

I am getting there though. Today fighting Firefox to get my passwords and bookmarks to new pc.

Then the same fight but with Thunderbird. (email program)

Beyond frustrating. I google on how to do it, it says copy this folder.
I copy that folder to a usb stck, and put it on new pc, only to find out it did not work.

It's almost taking all the fun out of building a new pc, but very happy with new hardware:

AMD Ryzen 5 2600 Wraith Boxed (3,4GHz 6 cores)
ASRock B450M Pro4
MSI Radeon RX 570 ARMOR 4G OC (vid card with 4 gig ram)
G.Skill Aegis F4-3000C16D-16GISB (So 16 gig of ram)

Most used OS wil be Linux (Suse Leap 15.1) (probably Suse tumbleweed later on)
Then Windows 10 pro for some games I want to play, but don't have a Linux version.

I am also a bit of a gamer, and my current pc, with an AMD Phenom II X4 and 8 gig ram, can't run F1 2017.
The cpu is missing an instruction set, so the game won't run.
Yesterday installed F1 2017 and Alien isolation on Linux at new pc, that took 19.7 gig and 14.8 gig hard disk space :o
New pc up and running, old pc up and running. :)

On new pc still need to install some programs, but today copied all my LMMS stuff from old pc to new pc.

Finally !

Now I can use lmms again, and see about those debugging tools, if I can help out the devs, with finding why there is an issue with my LMMS.

I will first try though, if the problem is still there on my new pc.
Good to see you got your new pc working, and old pc up and running.
And yeah, building a new PC can be tough sometimes. Good to see, you were able to overcome, the strange pc problems you were experiencing.


Gps quote:
"I am also a bit of a gamer, and my current pc, with an AMD Phenom II X4 and 8 gig ram, can't run F1 2017."


Holy crap! That hardware can't run F1 2017?
That game must be a serious power eater. :P

Speaking of F1 2017, I've been planning on playing that game, for a long time now. But I do play, the dreamcast PAL version, of F1 World Grand Prix 2, by Video Systems. That game is alot of fun. But the AI cars can be tough. :D
Well, about the phenom II X4, before I bought the game, I had searched and they said it could, with 8 gig ram.

But when I tried to start the game I got an error. It seemed the phenom II was missing an instruction set.Something like ssss3.
They offered me a refund, but I kept the game, and now can play it.

Yesterday had a look at debugging the appimage file of LMMS, but I get stuck.
I am probably misinterpreting, the manual.

Code: Select all

In the event a crash only occurs from a Linux AppImage:

    1) Run ./lmms-x.x.x.AppImage --appimage-extract
    2) Run export LD_LIBRARY_PATH="$(pwd -P)/squashfs-root/usr/lib:$LD_LIBRARY_PATH"
    3) Run gdb squashfs-root/usr/bin/lmms.real (an optionally second parameter is the path to a core dump)
    4) Type set sysroot ./squasfs-root and then set solib-search-path ./squashfs-root/usr/lib
    5) Type thread apply all bt full to get full backtrace of all threads.
I get confused / lost, around point 3 and 4. I will get help though, only need to be patient for now.

https://github.com/LMMS/lmms/issues/5104
squashfs-root?
I don't understand all commands.

The part I do get, you need to unpack the appimage file, and set some directories.

But what confused me, It sounded to me like you had to do this after a crash. But that does not make much sense.

I am now pretty sure, it's how you need to start the appimage file, so you get more info on why the LMMS gui is crashing / freezing.

Because I am on a new pc with a much newer Linux, I do know now for sure the problem is with LMMS, and not with my Linux version. Also somebody on Ubuntu said he has this problem.

The problem for the devs is, they need to know what is happening. If I can tell them the errors I get , and also when this happens, they will know how to fix it.

Will do some more testing, but one of my problems was it seemed to happen randomly.
But I might now know a way to have this issues appear.

Just browse through Synth1 presets. Then sooner or later the LMMS gui will go on a stike.
But I can't confirm this yet, and I need to be more specific, so the devs know what the problem is, and how they can reproduce it.

If they can't reproduce it, they can't fix it. :)

If they can't reproduce it, the problem could be only at my system, and not an general LMMS issue.
Made another step forward.
You should not start gdb first, but type something like:

Code: Select all

xxxx@linux-2ls4:~> gdb /home/guus/LMMS_appimage/squashfs-root/usr/bin/lmms.real

So it will start lmms with gdb keeping an eye out  :) 

warning: Loadable section ".dynstr" outside of ELF segments

Now I only need LMMS to act up, and off course it won't. Will try again though.
Hey Gps. I hope you're getting through with your house music.
I'll be making some house sound tuts soon.
Sounds good, I am not sure I still have the project. lol

Will have to take a look on old pc.
98 posts