"Keyboard icon" missing in LINUX AppImg MIDI input

Having trouble with LMMS? Ask about it here.
Hello everyone,
I am having trouble connecting my Yamaha cs2x to LMMS 1.2.0. I am running OpenSuse with LMMS from AppImage (the repository versions had trouble with loading soundfonts, so I had to use AppImage).

I have my keyboard connected to the computer via a MIDI to USB cable. This connection works, since I can see the USB MIDI interface:

Code: Select all

$ cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xd3a10000 irq 28
 1 [Interface      ]: USB-Audio - USB MIDI Interface
                      USB MIDI Interface at usb-0000:00:14.0-4, full speed
I have trouble connecting my MIDI controller to LMMS. I tried to follow the Wiki (https://lmms.io/wiki/index.php?title=Using_MIDI) and this detailed forum post (https://lmms.io/forum/viewtopic.php?t=2 ... df9455ccf2), but i'm stuck in the part, where I have to choose the MIDI interface. In my LMMS there is no "little keyboard icon":

Image

I have tried entering different channels and velocities, I have also tried to connect a knob to a controller using the autodetect function, but nothing worked. In the MIDI section of the settings I have tried every single interface except Dummy, and I have entered several values into the "device" field in the MIDI settings (I have entered "0", "1" and "hw:1").

Is there anything I am missing? Why is there no little keyboard icon?

Thank you in advance for any ideas on how to get it working. I was previously able to connect this keyboard to LMMS, but it was on a different version of LMMS and I absolutely do not remember, how I did it.
jenda wrote:
Fri Aug 16, 2019 9:21 am
Hello everyone,
I am having trouble connecting my Yamaha cs2x to LMMS 1.2.0. I am running OpenSuse with LMMS from AppImage (the repository versions had trouble with loading soundfonts, so I had to use AppImage).

I have my keyboard connected to the computer via a MIDI to USB cable. This connection works, since I can see the USB MIDI interface:

Code: Select all

$ cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xd3a10000 irq 28
 1 [Interface      ]: USB-Audio - USB MIDI Interface
                      USB MIDI Interface at usb-0000:00:14.0-4, full speed
I have trouble connecting my MIDI controller to LMMS. I tried to follow the Wiki (https://lmms.io/wiki/index.php?title=Using_MIDI) and this detailed forum post (https://lmms.io/forum/viewtopic.php?t=2 ... df9455ccf2), but i'm stuck in the part, where I have to choose the MIDI interface. In my LMMS there is no "little keyboard icon":

Image

I have tried entering different channels and velocities, I have also tried to connect a knob to a controller using the autodetect function, but nothing worked. In the MIDI section of the settings I have tried every single interface except Dummy, and I have entered several values into the "device" field in the MIDI settings (I have entered "0", "1" and "hw:1").

Is there anything I am missing? Why is there no little keyboard icon?

Thank you in advance for any ideas on how to get it working. I was previously able to connect this keyboard to LMMS, but it was on a different version of LMMS and I absolutely do not remember, how I did it.
I hope Linux/ midi- expert chimes in on this one. I know nothing on either. You have done everything correct afaik, so this problem is puzzling
My only input would be weather or not, you shot your pc down regularly? If its been a while since last cold-boot, do one, and retry the whole sequence -Obs!
OBS!
The o r d e r of connecting cables and turning HW on, vital!


Besides that, since you are new in Forum
Welcome jenda !
Here are all important links:
http://lmms.io/forum/viewtopic.php?f=1&t=4740
-A few rules and useful forum instructions
Thanks to musicbear for the response. It gave me motivation to try again from the scratch, which helped and I finally got it working.

The main issue was that I plugged in the cables wrong - i plugged the cable labelled OUT into the port OUT (and IN into IN). After switching the setup and plugging IN (cable) -> OUT (port) and OUT (cable) -> IN (port), I found a working configuration: "ALSA Raw-MIDI" and "hw:1" in the "Device field".
Congrats, it had me totally confused, why they that icon was missing.
Gps wrote:
Fri Aug 16, 2019 9:11 pm
Congrats, it had me totally confused, why they that icon was missing.
I guess they removed the option to manually select a MIDI device per instrument and you can only set it globally through the settings, which is why the "keyboard icon" is not needed anymore? It would be nice if the wiki was up to date, so it would not
confuse newcomers.
I think something is still missing in yours.

When I have time for I will have a look at mine.
I think this icon is still there. I will tell you, maybe cause you have only one device?
Icon is still here. LMMS 1.2 on opensuse 64 bit.

Who is online

In total there are 15 users online :: 0 registered, 0 hidden and 15 guests (based on users active over the past 5 minutes)
Most users ever online was 238 on Wed Oct 23, 2019 11:40 am

Users browsing this forum: No registered users and 15 guests