Main Menu Bar

en

The main menu bar gives you various options to control the overall functioning of LMMS:
Mainmenubar.png


Contents

Project Menu[edit]

The Project menu allows you to load, save and export projects, import MIDI files and Hydrogen files. New in 1.0.0 is that you easily can save new versions of your song.

Mainmenubar1-edit.png

This does not include a project that you have just created and saved, so you have to open the project at least once before it will show up in this menu.

In LMMS you have two project-options:
1) <myname.MMP>

Saving as .MMP creates a XML-file, that can be read in any code-editor. Avoid text-editors, like msWord, because that will add editor-formatting, and it will destroy the project!

2) <myname.MMPZ>

Saving as .MMPZ creates a coded and compressed file, that cant be read in any editor. The benefit is that MMPZ files are compressed, and therefore significantly smaller on disk.

Templates let you make a collection of different "Standards". You can have one template for Rock, and another for Trance, and so on. Templates can be cool, but avoid the pitfall of always making all your music in a genre, with the same instruments.

No MP3 file export support is planned. Once you have chosen a name and location to save the file, you then get presented with a dialog:
This allows you to choose the format of the file and for OGG files, the bit rate and bit rate management method (these settings are ignored for WAV files). Please note that, at this stage, the format chosen here and the extension you used on the file in the export file dialog are not synchronised automatically - you must set them the same manually to end up with a file which is named correctly for its content. You can also choose whether to use the High Quality Mode when performing the song.
On pressing 'OK' the song will be performed from where the playback point was last set. To get the entire song exported you should check that the playback mark is at the start of the song before exporting it.

Edit Menu[edit]

Mainmenubar2 1.1.0.png

The first two options in this menu are Undo and Redo. These can be also accessed by pressing the common keys Ctrl-Z and Shift-Ctrl-Z, respectively.
They allow you to step backward, or forward, through a history of edits to your project, reversing mistaken actions or re-applying them.

In this version the undo feature only works correctly for some forms of editing. In particular, in the Piano Roll Editor the bulk move, copy and paste facilities using the selection tool and/or clipboard do not get undone or redone correctly. The developers are aware of this problem and are working on a fix in a future version.

The third option is Settings, which opens the Settings dialog.


Tools Menu[edit]

Mainmenubar3 1.1.0.png

The only option currently in this menu is the LADSPA Plugin Browser. The LADSPA Plugin Browser can be used to view information about available LADSPA Plugins, and the alike.




Help Menu[edit]

Mainmenubar4 1.1.0.png

There are three items in the Help menu.

When you click on any part of a LMMS window, you will then see the contextual help for this item. Much of the help is in place but some items are still awaiting text being written for them.


Navigation[edit]

Prev: Video tutorials Up: Manual Next: Tool Bar


Attribution. In addition to the history page this article is based on the previous article for the 0.4 series [1]