LMMS Wiki has been archived and it is now read-only. If you are interested in writing documentation or tutorials for LMMS, please move to https://docs.lmms.io/user-manual/.

Main Menu Bar

From LMMS Wiki
Jump to navigation Jump to search

en

The main menu bar Mainmenubar.png gives you options to control the overall features of LMMS.

File Menu

The File-menu allows you to load, save and export projects, and import MIDI files. New in 1.0.0 is that you now have version-control for projects.

Mainmenubar1-edit.png
  • New creates a new project.
  • Open gives you a dialog to choose an existing project file to open.
  • Recently opened Projects opens up a submenu listing all the recent project files you have opened, so that you can easily open a project you were recently working on.
  • Save saves the current project if it has already been saved. If not you will be propted for a name for the project.





In LMMS you have two types of project-options: .MMP & .MMPZ
Lets say you want to save the project myname, you can save as :
1) myname.MMP

Saving as .MMP creates a XML-file, that can be read in any code-editor. Avoid text-editors, like msWord, because that will add editor-formatting, and it will destroy the project! If a MMP-file somehow is 'damaged', -and we all know that damage do happen to files, most often -at least part of the project can be saved!

Second option:
2) myname.MMPZ

Saving as .MMPZ creates a compressed file, that cant be read in any editor. The benefit is that the compressed MMPZ files are significantly smaller on disk, so the descission between MMP or MMPZ, depends mostly on your harddrive storage capacity.

Save as new version saves the current project with an additional number, starting with 01. Next time you save as new version it will be "myname-0<nm>".
This is known as version-control, and gives you the option to revert to previous versions of your project.

Save As gives you a dialog to choose a (new) location and name to save your project in. You can also choose to save your project as a template. If you want to change the default template, you can save a template called default.mpt and put it in a (new) folder called templates in your project folder. UserName/lmms/projects/templates/ Templates let you make a collection of different "Standards". You can have one template for Rock, and another for Trance, and so on. Templates can be cool, but avoid the pitfall of always making all your music in a genre, with the same instruments.

Import allows you to import MIDI-files as Soundfont-instrument and drum lines.

Export allows you to export your song as an uncompressed WAV file or compressed OGG and MP3-files.
Once you have chosen a name and location to save the file, you then get presented with a dialog:
Export window 1.0.png
This allows you to choose the format of the file and for OGG files, the bit rate and bit rate management method (these settings are ignored for file-types that does not support them).

In addition you have the options
Export as loop This will create a file, that has no 'gab' in the end, and therefore can loop perfectly.
Export between loop-markers This let you export only the part of your project, that is inside the loop-markers in song-editor

Export-tracks
First it is smart to create a folder on a full-right-partition of your pc. Stay away for anything in the OS area! Windows will not let you use it! Your 'Document' folder could be used, but if you use a SSD<= 125GB, you should select, either a storage disk, if one is installed, or a USB. Now you have defined a folder:

  • Choose File| Export Tracks
  • Choose export-file-format
  • Browse for the folder where you want the export-files -the one you just made!
  • Press save

In the Export-setting-UI choose additional export-settings of your choice

  • Press Start

Lmms runs through your project ones for every track! You should not press any controller during this process! The result is one sound-file, for each project-track, in the folder you made as first item in this sequence. Each exported track is named in sequence, starting with: '1_<name-of-track>.<ext> , 2_<name-of-track>.<ext> to ... n_<name-of-track>.<ext>


On pressing 'OK' the export will be executed.

Quit exits LMMS. You will be asked if you want to save your project if you have done any work on it since the last save or since you created it.

Edit Menu

Mainmenubar2 1.1.0.png

The first two options in this menu are Undo and Redo. These can be also accessed by pressing the common keys Ctrl-Z and Shift-Ctrl-Z, respectively.
They allow you to step backward, or forward, through a history of edits to your project, reversing mistaken actions or re-applying them.

The third option is Settings, which opens the Settings dialog. In this section everything is explained in detail. Read that before you start using LMMS.


Tools Menu

Mainmenubar3 1.1.0.png

The only option currently in this menu is the LADSPA Plugin Browser. The LADSPA Plugin Browser can be used to view information about available LADSPA Plugins. The gadgets has no practical function.




Help Menu

Mainmenubar4 1.1.0.png

There are three items in the Help menu.

Help opens the wiki's Main Page
What's This? Is only a placeholder, for a planned feature, that changes your cursor into a help cursor.
When you click on any part of a LMMS window, you will then see the contextual help for this item. Much of the help is in place but some items are still awaiting text being written for them.
About gives you a dialog which lists the LMMS program version, its home page, its key developers, translation information if you are using LMMS in a language other than English, and the GNU GPL license that the software is released under.
One thing from this license should be noted:
Everyone can use the LMMS codebase and build own releases of LMMS, but any and all added and or edited code, must be shipped in full with the software!

For you as a LMMS-user, this has one serious implication: Unless you have full trust in a person who release LMMS, you should never install that software!
Only get and install LMMS from http://lmms.io/download !


Navigation

Prev: Video tutorials Up: Manual Next: Tool Bar


Attribution. In addition to the history page this article is based on the previous article for the 0.4 series [1]